如AutoCAD2014、2015、2016、2017、2018、2019等软件平台上,在加载CAD类二次开发软件(如飞时达工程类设计软件、天正建筑设计软件等),会提示文件加载安全提示:“可执行文件超出指定的受信任的位置”,您要执行什么操作?如下图所示:

AutoCAD软件打开提示:“可执行文件超出指定的受信任的位置”

       AutoCAD软件打开提示:“可执行文件超出指定的受信任的位置”原因分析: 

       其实是AutoCAD软件高平台上,为什么安全起见,只添加加载受信任的ARX类文件,防止AutoCAD软件中病毒。

       AutoCAD软件打开提示:“可执行文件超出指定的受信任的位置”解决办法:

      1、如果你对所加载的CAD类二次开发软件比较信任的话,就按下列方法修改,很方便,进入到CAD菜单【工具】→【选项】

AutoCAD软件打开提示:“可执行文件超出指定的受信任的位置”

        在选项对话框中,再找到【系统】选项,再找到“可执行文件设置”这一项,选择“从所有位置加载,不显示警告”,就OK了!

AutoCAD软件打开提示:“可执行文件超出指定的受信任的位置”

      2、修改变量TRUSTEDPATHS的值

      就是说修改CAD系统变量。即将你的程序所在的路径添加到该系统变量中,以后加载你的程序就不会再提示了。

      在CAD的命令行中输入

      命令: TRUSTEDPATHS
      输入 TRUSTEDPATHS 的新值,或输入 . 表示无 <"D:***Arx***…">

      将你程序的路径写入TRUSTEDPATHS系统变量。多个路径中间用“;”分割。以“…”结尾表示该路径下的所有子路径也在信任路径列表中。

规范网收集CAD教程

发表评论

您的电子邮箱地址不会被公开。